Vanished thread

CougTek

Serial computer killer
Joined
Jan 21, 2002
Messages
8,692
Location
Québec, Québec
#1
The Pub thread "I don't want to buy a used car" is missing. Is it just me or this thread vanished? I tried the search and it doesn't show anywhere. I posted there not too long ago. Where is it?

It's late and I'm tired, but I don't think I'm THAT tired as to not be able to find a thread I know exist.
 

CougTek

Serial computer killer
Joined
Jan 21, 2002
Messages
8,692
Location
Québec, Québec
#3
It's good to know that someone else noticed it. I was starting to think that I was delusional and dreaming about stuff that never was. Now if you just excuse me, I'll take a moment to walk to the middle of the street and scream "I'M NOT CRAZY!, I'M NOT CRAZY, HAAHAHAHAAHAHAAAHAAAAAAA!" and then I'll come back.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,889
Location
USA
#4
I forgot to look into it after you sent me that message. I don't know what happened to it, but it was not intentionally removed. It's likely in a backup somewhere, the trick is, how to merge it back in to the forum.
 

BingBangBop

Storage is cool
Joined
Nov 15, 2009
Messages
667
#5
My assumption is that if one thread has unintentionally disappeared, then there are others too. Database corruption?
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,889
Location
USA
#6
My assumption is that if one thread has unintentionally disappeared, then there are others too. Database corruption?
There is no corruption. I ran checks on the database and there were no errors. The other reason I feel this isn't corruption is that I looked back through the moderator and admin logs to see if there was anything happening and it looks like it was my fault. There is a group of entries on the evening I upgraded the software. You can see the date and times all happened at 22:25 on feb 27th in the screen capture attached to the thread. I was doing tests for permissions and moderation and somehow I must have selected the "I don't want to buy a used car" thread and accidentally deleted it with the other test threads. :( Sorry for the mistake, I was not aware that thread was selected.

I know I have a back from 2012-02-27-2236 and 2012-02-27-0300 according to my saved files log. The issue is that these are both pre-upgrade database saves from version 3.8 of the forum software. I'll need to do some work to figure out how to restore the content in the new forum.

mistake.png
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
14,984
Location
USA
#7
Hey, you are doing great. One thread deleted in ten years compared to SR deleting their whole database in the MBF.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,889
Location
USA
#8
Hey, you are doing great. One thread deleted in ten years compared to SR deleting their whole database in the MBF.
Woo hoo...now it'll be a task to see if I can get that thread back. Limited searching suggests it's not so trivial to revive a single thread. :-(
 

CougTek

Serial computer killer
Joined
Jan 21, 2002
Messages
8,692
Location
Québec, Québec
#9
If it's too much trouble transfering it, you could just recreate it manually. You can edit and therefore create posts for members of the forum so you just have to copy what we wrote back thne to a new thread you'd create and change the dates of the posts according to the original ones. It was only a 200-300 posts thread so it should be a breeze.
 
Top