Results 1 to 5 of 5

Thread: Intel network card: How do I disable PXE boot?

  1. #1
    Wannabe Storage Freak
    Join Date
    Feb 2002
    Posts
    1,080

    Intel network card: How do I disable PXE boot?

    I bought a few used Intel Pro/100 network cards of some subtype. After installing in a system, shortly after the usual IDE device detection routine, one of the cards prompts this to come up:

    Code:
    Initializing Intel (R) Boot Agent Version 3.0.05
    PXE 2.0 Build 078 (WfM 2.0), RPL V2.73
    And then after the BIOS is finished doing its little dance (PS: get down tonight), the following appears when the system finally tries to boot an OS:

    Code:
    Intel (R) Boot Agent Version 3.0.05
    Copyright (C) 1997-2000, Intel Corporation
    PXE-E61: Media test failure, check cable
    PXE-M0F: Exiting Intel PXE ROM
    It's not the "Media test failure" I'm inquiring about (the cable really is just unplugged). I'd like to know how to stop the PXE from trying to boot ... umm, something ... from off the network. I'm half tempted to plug the card into an Internet-facing network segment and see if it actually connects to something, but I'm too old for that sort of long-shot craziness these days.

    I assumed that there was some key sequence I could press during the boot sequence that would get me into some kind of control for the PXE ROM (something like an Adaptec SCSI card has the CTRL+A option). The few obvious ones I tried (F1, F2, Del) did nothing.

    Does anyone know how to disable PXE boot on an Intel card?

  2. #2
    Wannabe Storage Freak
    Join Date
    Feb 2002
    Posts
    1,080
    Well, in case it's helpful to someone else someday, I found the answer.

    CTRL+S

    You need to press CTRL+S while the "Initializing Intel (R) Boot Agent Version X.X.XX" message is displayed. Additional information about utilities that can modify PXE and RPL settings on Intel cards is available here.

    Happy booting!

  3. #3
    Storage? I am Storage! Tannin's Avatar
    Join Date
    Jan 2002
    Location
    Ballarat, Oz
    Posts
    4,198
    Thanks i. That's a good one to try to remember. (And a pox on Intel for not putting that information on the screen in the first place.)

  4. #4
    Wannabe Storage Freak
    Join Date
    Feb 2002
    Posts
    1,080
    Well, it turns out it really is a lot like how Adaptec deals with their cards' internal settings. Similar to how you can configure an Adaptec SCSI card to display or not display its "Press CTRL + A to access setup" message, PXE-capable Intel network cards can also be configured to display or not display a message about their CTRL + S option.

    The difference is, Adaptec has their message turned on by default, but Intel has their message turned off by default. So yes, I think they still deserve some blame there.

    Once you're in the Intel PXE setup, you can turn the hint message on (which I've done in case I forget the key combination someday.)

  5. #5
    Storage? I am Storage! Tannin's Avatar
    Join Date
    Jan 2002
    Location
    Ballarat, Oz
    Posts
    4,198
    So once you already know what the control key combination is, you can turn on the message that lets you find out what the control key combination is.

    Bahhh....

    And they call themselves engineers .....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •